rabbitmq-diagnostics(8) -- RabbitMQ diagnostics, monitoring and health checks tools



  • Rabbitmq Manages: https://www.rabbitmq.com/manpages.html

    RABBITMQ-DIAGNOSTICS(8)	  BSD System Manager's Manual  RABBITMQ-DIAGNOSTICS(8)
    
    NAME
         rabbitmq-diagnostics -- RabbitMQ diagnostics, monitoring and health
         checks tools
    
    SYNOPSIS
         rabbitmq-diagnostics [-q] [-s] [-l] [-n node] [-t timeout] command
    			  [command_options]
    
    DESCRIPTION
         rabbitmq-diagnostics is a command line tool that provides commands used
         for diagnostics, monitoring and health checks of RabbitMQ nodes.  See the
         RabbitMQ documentation guides:
    	   https://www.rabbitmq.com/documentation.html
         to learn more about RabbitMQ diagnostics, monitoring and health checks.
    
         rabbitmq-diagnostics allows the operator to inspect node and cluster
         state. A number of health checks are available to be used interactively
         and by monitoring tools.
    
    
         By default if it is not possible to connect to and authenticate with the
         target node (for example if it is stopped), the operation will fail.  To
         learn more, see the RabbitMQ Monitoring guide:
    	   https://www.rabbitmq.com/monitoring.html
    
    OPTIONS
         -n node
    	     Default node is "rabbit@target-hostname", where target-hostname
    	     is the local host.	 On a host named "myserver.example.com", the
    	     node name will usually be "rabbit@myserver" (unless
    	     RABBITMQ_NODENAME has been overridden).  The output of "hostname
    	     -s" is usually the correct suffix to use after the "@" sign.  See
    	     rabbitmq-server(8) for details of configuring a RabbitMQ node.
    
         -q, --quiet
    	     Quiet output mode is selected.  Informational messages are
    	     reduced when quiet mode is in effect.
    
         -s, --silent
    	     Silent output mode is selected.  Informational messages are
    	     reduced and table headers are suppressed when silent mode is in
    	     effect.
    
         -t timeout, --timeout timeout
    	     Operation timeout in seconds.  Not all commands support timeouts.
    	     Default is infinity.
    
         -l, --longnames
    	     Must be specified when the cluster is configured to use long
    	     (FQDN) node names.	 To learn more, see the RabbitMQ Clustering
    	     guide:
    		   https://www.rabbitmq.com/clustering.html
    
         --erlang-cookie cookie
    	     Shared secret to use to authenticate to the target node.  Prefer
    	     using a local file or the RABBITMQ_ERLANG_COOKIE environment
    	     variable instead of specifying this option on the command line.
    	     To learn more, see the RabbitMQ CLI Tools guide:
    		   https://www.rabbitmq.com/cli.html
    
    COMMANDS
         Most commands provided by rabbitmq-diagnostics inspect node and cluster
         state or perform health checks.
    
         Commands that list topology entities (e.g. queues) use tab as column
         delimiter.	 These commands and their arguments are delegated to rabbit-
         mqctl(8).
    
         Some commands ( list_queues, list_exchanges, list_bindings and
         list_consumers) accept an optional vhost parameter.
    
         The list_queues, list_exchanges and list_bindings commands accept an
         optional virtual host parameter for which to display results.  The
         default value is "/".
    
         help
    
    	     Displays general help and commands supported by
    	     rabbitmq-diagnostics.
    
         ping
    
    	     Most basic health check. Succeeds if target node (runtime) is
    	     running and rabbitmq-diagnostics can authenticate with it suc-
    	     cessfully.
    
         memory_breakdown [--unit memory_unit]
    
    	     Displays node's memory usage by category.	Supported memory units
    	     are:
    
    	     o	 bytes
    
    	     o	 megabytes
    
    	     o	 gigabytes
    
    	     o	 terabytes
    
    	     See RabbitMQ Memory Use guide:
    		   https://www.rabbitmq.com/memory-use.html
    	     to learn more.
    
    	     Example:
    
    		   rabbitmq-diagnostics memory_breakdown --unit gigabytes
    
         server_version
    
    	     Reports target node's version.
    
    	     Example:
    		   rabbitmq-diagnostics server_version -q
    
         erlang_version
    
    	     Reports target node's Erlang/OTP version.
    
    	     Example:
    		   rabbitmq-diagnostics erlang_version -q
    
         maybe_stuck
    
    	     Periodically samples stack traces of all Erlang processes
    	     ("lightweight threads") on the node. Reports the processes for
    	     which stack trace samples are identical.
    
    	     Identical samples may indicate that the process is not making any
    	     progress but is not necessarily an indication of a problem.
    
    	     Example:
    		   rabbitmq-diagnostics maybe_stuck -q
    
         runtime_thread_stats [--sample-interval interval]
    
    	     Performs sampling of runtime (kernel) threads' activity for
    	     interval seconds and reports it.
    
    	     For this command to work, Erlang/OTP on the target node must be
    	     compiled with microstate accounting support and have the run-
    	     time_tools package available.
    
    	     Example:
    		   rabbitmq-diagnostics runtime_thread_stats --sample-interval
    		   15
    
         tls_versions
    
    	     Lists all TLS versions supported by the runtime on the target
    	     node.  Note that RabbitMQ can be configured to only accept a sub-
    	     set of those versions, for example, SSLv3 is disabled by default.
    
    	     See RabbitMQ TLS guide:
    		   https://www.rabbitmq.com/ssl.html
    	     to learn more.
    
    	     Example:
    		   rabbitmq-diagnostics tls_versions -q
    
         erlang_cookie_hash
    
    	     Outputs a hashed value of the shared secret used by the target
    	     node to authenticate CLI tools and peers. The value can be com-
    	     pared with the hash found in error messages of CLI tools.
    
    	     See RabbitMQ Clustering guide:
    		   https://www.rabbitmq.com/clustering.html#erlang-cookie
    	     to learn more.
    
    	     Example:
    		   rabbitmq-diagnostics erlang_cookie_hash -q
    
         discover_peers
    
    	     Runs a peer discovery on the target node and prints the discov-
    	     ered nodes, if any.
    
    	     See RabbitMQ Cluster Formation guide:
    		   https://www.rabbitmq.com/cluster-formation.html
    	     to learn more.
    
    	     Example:
    		   rabbitmq-diagnostics discover_peers --timeout 60
    
         list_channels [channelinfoitem ...]
    	     See list_channels in rabbitmqctl(8)
    
         list_queues [-p vhost] [--offline | --online | --local] [queueinfoitem
    	     ...]
    	     See list_queues in rabbitmqctl(8)
    
         list_exchanges [-p vhost] [exchangeinfoitem ...]
    	     See list_exchanges in rabbitmqctl(8)
    
         list_bindings [-p vhost] [bindinginfoitem ...]
    	     See list_bindings in rabbitmqctl(8)
    
         list_connections [connectioninfoitem ...]
    	     See list_connections in rabbitmqctl(8)
    
         list_channels [channelinfoitem ...]
    	     See list_channels in rabbitmqctl(8)
    
         list_consumers [-p vhost]
    	     See list_consumers in rabbitmqctl(8)
    
         alarms
    
    	     Lists resource alarms, if any, in the cluster.
    
    	     See RabbitMQ Resource Alarms guide:
    		   https://www.rabbitmq.com/alarms.html
    	     to learn more.
    
    	     Example:
    		   rabbitmq-diagnostics alarms
    
         listeners
    
    	     Lists listeners (bound sockets) on this node. Use this to inspect
    	     what protocols and ports the node is listening on for client, CLI
    	     tool and peer connections.
    
    	     See RabbitMQ Networking guide:
    		   https://www.rabbitmq.com/networking.html
    	     to learn more.
    
    	     Example:
    		   rabbitmq-diagnostics listeners
    
         is_running
    
    	     Reports if RabbitMQ application is fully booted and running (that
    	     is, not stopped) on the target node.
    
    	     Example:
    		   rabbitmq-diagnostics is_running
    
         is_booting
    
    	     Reports if RabbitMQ application is currently booting (not
    	     booted/running or stopped) on the target node.
    
    	     Example:
    		   rabbitmq-diagnostics is_booting
    
    	     check_port_connectivity [-t <timeout>]
    
         check_running
    
    	     Health check that fails (returns with a non-zero code) if the
    	     RabbitMQ application is not running on the target node.
    
    	     If rabbitmqctl(8) was used to stop the application, this check
    	     will fail.
    
    	     Example:
    		   rabbitmq-diagnostics check_running
    
         check_local_alarms
    
    	     Health check that fails (returns with a non-zero code) if there
    	     are alarms in effect on the target node.
    
    	     See RabbitMQ Resource Alarms guide:
    		   https://www.rabbitmq.com/alarms.html
    	     to learn more.
    
    	     Example:
    		   rabbitmq-diagnostics check_local_alarms
    
         check_alarms
    
    	     Health check that fails (returns with a non-zero code) if there
    	     are alarms in effect on any of the cluster nodes.
    
    	     See RabbitMQ Resource Alarms guide:
    		   https://www.rabbitmq.com/alarms.html
    	     to learn more.
    
    	     Example:
    		   rabbitmq-diagnostics check_alarms
    
         check_port_connectivity
    
    	     Health check that fails (returns with a non-zero code) if any
    	     listener ports on the target node cannot accept a new TCP connec-
    	     tion opened by The check only validates if a new TCP connection
    	     is accepted. It does not perform messaging protocol handshake or
    	     authenticate.
    
    	     See RabbitMQ Networking guide:
    		   https://www.rabbitmq.com/networking.html
    	     to learn more.
    
    	     Example:
    		   rabbitmq-diagnostics check_port_connectivity
    
         check_protocol_listener
    
    	     Health check that fails (returns with a non-zero code) if the
    	     target node does not have a listener for the specified protocol.
    
    	     See RabbitMQ Networking guide:
    		   https://www.rabbitmq.com/networking.html
    	     to learn more.
    
    	     Example:
    		   rabbitmq-diagnostics check_protocol_listener mqtt
    
         check_port_listener
    
    	     Health check that fails (returns with a non-zero code) if the
    	     target node is not listening on the specified port (there is no
    	     listener that uses that port).
    
    	     See RabbitMQ Networking guide:
    		   https://www.rabbitmq.com/networking.html
    	     to learn more.
    
    	     Example:
    		   rabbitmq-diagnostics check_port_listener 5672
    
         status  See status in rabbitmqctl(8)
    
         cluster_status
    	     See cluster_status in rabbitmqctl(8)
    
         environment
    	     See environment in rabbitmqctl(8)
    
         report  See report in rabbitmqctl(8)
    
         list_global_parameters
    	     See list_global_parameters in rabbitmqctl(8)
    
         list_operator_policies [-p vhost]
    	     See list_operator_policies in rabbitmqctl(8)
    
         list_parameters [-p vhost]
    	     See list_parameters in rabbitmqctl(8)
    
         list_permissions [-p vhost]
    	     See list_permissions in rabbitmqctl(8)
    
         list_policies [-p vhost]
    	     See list_policies in rabbitmqctl(8)
    
         list_topic_permissions [-p vhost]
    	     See list_topic_permissions in rabbitmqctl(8)
    
         list_user_permissions username
    	     See list_user_permissions in rabbitmqctl(8)
    
         list_user_topic_permissions username
    	     See list_user_topic_permissions in rabbitmqctl(8)
    
         list_users
    	     See list_users in rabbitmqctl(8)
    
         list_vhosts [vhostinfoitem ...]
    	     See list_vhosts in rabbitmqctl(8)
    
         node_health_check
    	     Performs several health checks of the target node.
    
    	     Verifies the rabbit application is running and alarms are not
    	     set, then checks that every queue and channel on the node can
    	     emit basic stats.
    
    	     Example:
    		   rabbitmq-diagnostics node_health_check -n rabbit@hostname
    
    RabbitMQ Server		       January 29, 2019		       RabbitMQ Server
    

Log in to reply
 

© Lightnetics 2024